Install NSClient++ with msiexec

Forums NSClient++ support Install NSClient++ with msiexec

This topic contains 3 replies, has 2 voices, and was last updated by  Legacy Forum User 1 year, 8 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #2049

    Hello,

    I would like to install NSClient + + with the command msiexec but changing the default installation path. I tried the following command without success,

    msiexec /i “c:\temp\nsclient\NSClient++-0.3.8-win32.msi” /qn InstallType=1 TARGETDIR=”C:\NSClient\” /norestart

    msiexec /i “c:\temp\nsclient\NSClient++-0.3.8-win32.msi” /qn InstallType=2 TARGETDIR=”C:\NSClient\” /norestart

    msiexec /i “c:\temp\nsclient\NSClient++-0.3.8-win32.msi” /qn InstallType=1 INSTALLDIR=”C:\NSClient\” /norestart

    msiexec /i “c:\temp\nsclient\NSClient++-0.3.8-win32.msi” /qn InstallType=2 INSTALLDIR=”C:\NSClient\” /norestart

    msiexec /i “c:\temp\nsclient\NSClient++-0.3.8-win32.msi” /qn InstallType=1 INSTALLDIR=”C:\NSClient\” TARGETDIR=”C:\NSClient\” /norestart

    msiexec /i “c:\temp\nsclient\NSClient++-0.3.8-win32.msi” /qn InstallType=1 INSTALLDIR=”C:\NSClient\” TARGETDIR=”C:\NSClient\” /norestart

    msiexec /i “c:\temp\nsclient\NSClient++-0.3.8-win32.msi” INSTALLDIR=”C:\NSClient\”

    msiexec /i “c:\temp\nsclient\NSClient++-0.3.8-win32.msi” TARGETDIR=”C:\NSClient\”

    All tests installed in the default route “c:\program files\nsclient++\”

    Any idea? Thanks all.

    #8499

    I’m working my way through the MSI itself. It appears that the variable you need is not INSTALLDIR, but rather INSTALLLOCATION in this case.

    I’m having trouble figuring out how to tell it to always start the service after the install. START_SERVICE_ON_EXIT=1 appears to be what should do it, but it’s not working…

    Mark

    #8526

    Michael Medin
    Keymaster

    This is all a bit flaky in 0.3.x but improved in 0.4.x.

    In genral for 0.3.x you have the following to play with:

    {{{
    CONF_CAN_WRITE=1
    Means to update configuration (or not).

    KEEP_WHICH_CONFIG=NEW (or OLD)
    Which configuration to use.

    ARPCOMMENTS=NSClient++ is a
    ARPCONTACT=[email protected]
    ARPHELPLINK=http://nsclient.org
    ARPURLINFOABOUT=http://nsclient.org
    ARPURLUPDATEINFO=http://nsclient.org
    ARPHELPTELEPHONE=http://nsclient.org
    ARPPRODUCTICON=nsclient.exe
    HELP_LINK=http://nsclient.org/nscp/

    CONF_CHECKS=1
    Enable “default” checks

    CONF_NSCLIENT=1
    Configure NSCLientListsner module.

    CONF_NRPE=1
    Configure NRPEListsner module.

    CONF_NSCA=1
    Configure NSCA module.

    CONF_WMI=1
    Configure CheckWMI modeule.

    ALLOW_CONFIGURATION
    Allow changin configuration in the installer UI

    ALLOWED_HOSTS=
    settings/allowed_hosts

    NSCLIENT_PWD=
    settings/password

    INSCON_CONFIGURE=1
    unsure :P

    MAIN_CONFIGURATION_FILE=NSC.ini
    WHich file to read

    CUSTOM_CONFIGURATION_FILE=foobar.ini
    Which file to write

    All these control the tick boxes on exit.
    SHOW_START_ON_EXIT=0
    START_SERVICE_ON_EXIT=1
    SHOW_DONATE_ON_EXIT=0
    DONATE_ON_EXIT=0
    }}}

    IN addition to these there is some other things like someone detected INSTALLLOCATION and and TARGETDIR and what not but I am not an MSI expert so I am unsure which are usefull for what so someone feel free to educate me!

    // Michael Medin

    #9346

    Hi Michael, Mark,
    On Windows 7 this doesn’t work (TARGETDIR nor INSTALLLOCATION nor INSTALLDIR nor INSTALLTYPE=2).

    Can you specify the full command for installing NSCLIENT++ on non-default directory with msiexec ?

    Thanks!
    Noam.

    ———
    Update:
    Since the MSI probably need to be fixed, I found a workaround to solve my original problem – installing NSClient++ on many Windows 7 machines + updating NSClient.ini file – which was restricted under default install directory (Program Files), due domain policy:
    I’ve updated the ini file using msi2xml:
    [http://stackoverflow.com/a/5103912/658497]

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.