No data was received from host!

Forums NSClient++ support No data was received from host!

This topic contains 3 replies, has 1 voice, and was last updated by  Legacy Forum User 6 years, 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1453

    Installed Nagios
    Installed NSClient – Here is log file when I start

    2008-06-19 13:51:24: message:.\FileLogger.cpp:58: Starting to log for: NSClient++ – 0.3.2.9 2008-05-17

    2008-06-19 13:51:24: debug:.\NSClient++.cpp:401: Loading plugin: NRPE server…

    2008-06-19 13:51:24: debug:.\PDHCollector.cpp:122: Found countername: CPU: \Processor(_total)\% Processor Time

    2008-06-19 13:51:24: debug:.\PDHCollector.cpp:123: Found countername: UPTIME: \System\System Up Time

    2008-06-19 13:51:24: debug:.\PDHCollector.cpp:124: Found countername: MCL: \Memory\Commit Limit

    2008-06-19 13:51:24: debug:.\PDHCollector.cpp:125: Found countername: MCB: \Memory\Committed Bytes

    2008-06-19 13:51:24: debug:.\NSClient++.cpp:401: Loading plugin: NSClient server…

    2008-06-19 13:51:24: debug:d:\Documents and Settings\mickem\Mina dokument\Visual Studio 2005\Projects\NSCP\tags\0.3.2\include\Socket.h:627: Bound to: 0.0.0.0:5666

    2008-06-19 13:51:24: debug:d:\Documents and Settings\mickem\Mina dokument\Visual Studio 2005\Projects\NSCP\tags\0.3.2\include\Socket.h:627: Bound to: 192.168.100.253:1248

    I get the message no data received from host on the Nagios screen

    #6873

    then I would say there is a problem with you check because if it had “tried” to connect to the server you would have seen that.

    Are you sure you have the right port/host?

    Also try running fro mthe command line instead of nagios (it is usually simpler).

    // MickeM

    #6877

    I launched the NSClient test on remote machine .. it is working as i checked cpuload

    It seems that Nagios is not receiving the data from the client??

    #6880

    nagios is not really going to “receive” any data.
    The check you configure will collect the data (unless you use passive checks) which it does by running check_nt/check_nrpe so thyr the same command you have configured in nagios from the command line and see if you can get things working from there.

    // MickeM

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.